Cloud Access Email OTP Delivery
Incident Report for SecureAuth Service
Resolved
Email OTP delivery issue has been resolved. We will continue to monitor. Thank you for your patience.
Posted about 1 month ago. Sep 06, 2017 - 22:23 UTC
Identified
We are currently working an issue regarding Cloud Access Email OTP delivery. We are working with our vendor to resolve this issue and apologize for any inconvenience. We will update this incident as soon as we have more information.
Posted about 1 month ago. Sep 06, 2017 - 22:19 UTC