Investigating Voice OTP Delivery Issues with Specific Carriers in the US
Incident Report for SecureAuth Service
Resolved
Voice OTP delivery issues were resolved. More information will be provided.
Posted about 1 year ago. Jul 20, 2017 - 04:48 UTC
Investigating
We are currently investigating Voice OTP delivery issues with specific carriers in the US. We will provide more information as we receive updates from our service provider.
Posted about 1 year ago. Jul 13, 2017 - 19:33 UTC