Investigating SMS Delivery Issues to Verizon (US)
Incident Report for SecureAuth Service
Postmortem

From our service provider:

What happened

From 30/04/2018 10:28 UTC to 30/04/2018 16:23 UTC, US Toll Free and shortcode traffic failed, while delivery receipts were still indicating successful delivery.

Causes

While performing a connection migration with one of our US suppliers, live traffic was redirected to a test environment instead of the new production environment, due to a human error in the migration activity.

Corrective Actions

Internal tickets have been created to ensure the following corrective actions take place as a result:

Create a process for real-time communications with our provider during connection migrations.

Create additional monitoring during and after connection migrations impacting live traffic.

Improve our process for customer communications during incidents.

Posted 4 months ago. Jun 07, 2018 - 00:08 UTC

Resolved
SMS delivery issues to Verizon have been resolved. Post-mortem to follow once the investigation is complete.
Posted 6 months ago. Apr 30, 2018 - 18:54 UTC
Monitoring
We have been notified that SMS delivery to Verizon has improved, but there may be latency or delays. We are currently monitoring the situation and will provide further updates when the issue is fully resolved.
Posted 6 months ago. Apr 30, 2018 - 14:38 UTC
Investigating
We are currently investigating SMS delivery issues to Verizon users. Our service provider is currently investigating the issue, and we will provide an update as soon as we receive more information.
Posted 6 months ago. Apr 30, 2018 - 13:48 UTC