SMS Delivery Delays
Incident Report for SecureAuth Service
Resolved
The issue has been resolved. We will remain with our secondary service provider until further notice.

Update: We are now back to our primary provider.
Posted 9 days ago. Mar 13, 2019 - 23:29 UTC
Monitoring
We have changed to our secondary service provider and users should see improved SMS delivery times. We will continue to monitor the situation and will return to our normal service provider once the issue has been fully resolved.
Posted 9 days ago. Mar 13, 2019 - 20:33 UTC
Identified
Please be advised: Our SMS provider has informed us that due to local issues with their suppliers in USA & Canada, End Users might experience some delays in the delivery of the SMS traffic for a few destinations.

The downstream suppliers have identified the issue and are working to resolve this. We will keep you updated on any progress.

Customer Impact: End users may experience delays in delivery of SMS OTPs.
Posted 9 days ago. Mar 13, 2019 - 19:32 UTC
This incident affected: SMS Service (Nexmo SMS API).