Intermittent SMS Delivery Issues
Incident Report for SecureAuth Service
Resolved
Our service providers have informed us that the issue is resolved.
Posted 12 months ago. Apr 09, 2018 - 19:56 UTC
Investigating
We are investigating reports of SMS delivery issues. An update will be sent out once we have more information from our service providers.
Posted 12 months ago. Apr 09, 2018 - 15:56 UTC