Slow SMS Delivery
Incident Report for SecureAuth Service
Resolved
This incident has been resolved.
Posted Apr 03, 2020 - 17:01 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 03, 2020 - 13:40 UTC
Investigating
We are currently investigating this issue.
Posted Apr 03, 2020 - 13:05 UTC
This incident affected: SecureAuth Cloud Services (SMS Service - US1).