IAM SaaS US Region - Something has gone wrong

Incident Report for SecureAuth Service

Resolved

The problem has been resolved.
Resolved - The component IAM SaaS US Region is down and we're working on it.
Posted Jun 11, 2025 - 10:37 PDT

Identified

Our team of engineers are investigating.
Firing - The component IAM SaaS US Region is down and we're working on it.
Posted Jun 11, 2025 - 10:31 PDT
This incident affected: CIAM (US Region).