T-Mobile SMS Delivery Issues
Incident Report for SecureAuth Service
Resolved
This incident has been resolved
Posted Jun 16, 2020 - 07:05 PDT
Update
Work from T-Mobile engineering team is still ongoing, more information will be provided as it is available to us.
Posted Jun 15, 2020 - 21:56 PDT
Update
We are continuing to investigate this issue.
Posted Jun 15, 2020 - 17:31 PDT
Investigating
We are observing delays in delivery of outbound SMS to the T-Mobile network in the US due to issues with the T-Mobile network. We are actively monitoring T-Mobile and our SMS providers for updates.

Customer impact: End users with T-Mobile may have delays or not receive SMS messages.
Posted Jun 15, 2020 - 13:31 PDT
This incident affected: SecureAuth Cloud Services (SMS Service - US1, SMS Service - US2) and SecureAuth Titan Services (SMS Service).