Intermittent Issues with the SMS Service
Incident Report for SecureAuth Service
Resolved
The issue has been resolved - RCA to follow
Posted Oct 03, 2023 - 18:40 PDT
Investigating
We are currently investigating an SMS Service issue that is impacting multiple customers - other OTP methods appear to be working without issue
Posted Oct 03, 2023 - 18:25 PDT
This incident affected: SecureAuth Titan Services (SMS Service).