DynDNS Maintenance Affects Cloud Service Availability
Incident Report for SecureAuth Service
Postmortem

Incident Description:
Any service resolving to us-services.secureauth.com experienced failures to resolve against the URL while making any attempt to contact cloud services including, but not limited to: datastore connection and multifactor services.

Root Cause:
One of our main DNS providers have changed their nameserver IPs; this directly resulted in our need to update our glue records, which directly caused our loss of name resolution.

Resolution/Corrective Actions:
Our glue records have been updated respectively to match our DNS provider's new nameserver IPs. We have ensured we are now enlisted on our DNS provider's notifications when major infrastructure changes occur on their end to prevent another occurrence as such.

Posted Apr 26, 2022 - 15:34 UTC

Resolved
DynDNS is the DNS provider for SecureAuth. During maintenance that was performed on Saturday around 9:30 AM PDT, DynDNS change the IP addresses associated with SecureAuth services. This caused connections to SecureAuth services to fail until the client resolved to the new IP addresses. Services were restored around 10:45 AM PDT.
Posted Apr 23, 2022 - 16:30 UTC