SecureAuth is investigating intermittent issues with the Voice notification service.
Incident Report for SecureAuth Service
Resolved
This incident has been resolved.
Posted May 01, 2020 - 14:04 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 01, 2020 - 13:20 PDT
Investigating
We are currently investigating this issue.
Posted May 01, 2020 - 13:14 PDT
This incident affected: SecureAuth Titan Services (Telephony Service).