SecureAuth SaaS Customer Service Disruption
Incident Report for SecureAuth Service
Resolved
This incident has been resolved.
Posted Feb 03, 2021 - 16:26 PST
Identified
We are currently resolving a service disruption for SecureAuth SaaS customers. We will continue to provide updates as we receive more information.
Posted Feb 03, 2021 - 15:44 PST