Intermittent Failure For Cloud Only IdP Connection
Incident Report for SecureAuth Service
Postmortem

Incident Description:
Any service resolving to us-services.secureauth.com experienced failures to resolve against the URL while making any attempt to contact cloud services including, but not limited to: datastore connection and multifactor services.

Root Cause:
One of our main DNS providers have changed their nameserver IPs; this directly resulted in our need to update our glue records, which directly caused our loss of name resolution.

Resolution/Corrective Actions:
Our glue records have been updated respectively to match our DNS provider's new nameserver IPs. We have ensured we are now enlisted on our DNS provider's notifications when major infrastructure changes occur on their end to prevent another occurrence as such.

Posted Apr 26, 2022 - 08:32 PDT

Resolved
This incident has been resolved.
Posted Apr 25, 2022 - 09:53 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 23, 2022 - 11:28 PDT
Investigating
We are currently investigating this issue.
Posted Apr 23, 2022 - 09:59 PDT