IAM SaaS EU Region - Something has gone wrong

Incident Report for SecureAuth Service

Resolved

The problem has been resolved.
Resolved - The component IAM SaaS EU Region is down and we're working on it.
Posted May 08, 2025 - 18:32 PDT

Identified

Our team of engineers are investigating.
Firing - The component IAM SaaS EU Region is down and we're working on it.
Posted May 08, 2025 - 18:31 PDT
This incident affected: CIAM (EU Region).