Intermittent Issues with Dashboard Service
Incident Report for SecureAuth Service
Resolved
This incident has been resolved.
Posted May 08, 2021 - 08:27 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 27, 2021 - 03:20 UTC
Investigating
We are currently investigating intermittent issues with the dashboard service. We will provide further updates as we receive more information.
Posted Apr 26, 2021 - 18:33 UTC
This incident affected: SecureAuth Titan Services (Dashboard Service).