IAM SaaS US Region - Something has gone wrong

Incident Report for SecureAuth Service

Resolved

This incident has been resolved.
Posted Aug 21, 2025 - 13:45 PDT

Monitoring

We have applied the resolution and are no longer seeing 500 error spikes. We will continue to monitor.

We will provide an update once available, please reach out to support@secureauth.com with any questions
Posted Aug 21, 2025 - 12:59 PDT

Identified

IAM SaaS US Region is experiencing performance degradation, which is leading to an increase in 500 errors. We have identified the issue and are implementing a resolution.

We will provide an update once available, please reach out to support@secureauth.com with any questions
Posted Aug 21, 2025 - 12:13 PDT
This incident affected: CIAM (US Region).