PUSH service Errors
Incident Report for SecureAuth Service
Postmortem

Problem Description: On October 28, 2023 at approximately 3:00pm Pacific Time, the certificate utilized between the SecureAuth Push Service and the Apple Push Service expired and SecureAuth could no longer send push requests to iOS devices. Android devices were not impacted.

Resolution:
SecureAuth regenerated the certificate and uploaded it to the Push Service and iOS devices were once again receiving Push Notifications for authentication.

Corrective Actions:
Implement fix for certificate renewal notification to necessary stakeholders
Implement additional certificate monitors and system alerts

Posted Oct 31, 2023 - 20:48 PDT

Resolved
The fix for ios devices is now resolved. RCA will Follow.
Posted Oct 28, 2023 - 17:39 PDT
Identified
We identified the issue. We are implementing the fix.
Posted Oct 28, 2023 - 17:28 PDT
Update
We have Identified the issue we are working on implementing a fix.
Posted Oct 28, 2023 - 17:25 PDT
Investigating
We are currently investigating a Push Service issue that is impacting IOS devices - other Devices working without any issues.
We will continue to provide updates .
Posted Oct 28, 2023 - 17:14 PDT
This incident affected: SecureAuth Titan Services (Push-to-Accept Service).