If you have any questions regarding this issue please log a ticket at https://support.secureauth.com. Our teams are on standby and are ready to assist.
Posted Oct 20, 2025 - 17:29 PDT
Update
All affected service issues are now operational. We will continue to work closely with AWS and monitor their recovery efforts. Performance degradation may continue as recovery efforts on AWS services are performed. We will be closely monitoring our systems throughout this effort.
If you have any questions regarding this issue or require assistance with using alternative MFA, please log a ticket at https://support.secureauth.com. Our teams are on standby and are ready to assist.
Posted Oct 20, 2025 - 12:32 PDT
Update
PUSH services to Android devices may experience degraded performance. All affected service issues are now operational.
We will keep the Secureauth status page updated with any changes, including when service issues are resolved.
If you have any questions regarding this issue or require assistance with using alternative MFA, please log a ticket at https://support.secureauth.com. Our teams are on standby and are ready to assist.
Posted Oct 20, 2025 - 12:26 PDT
Update
All affected service issues are now operational. We will continue to work closely with AWS and monitor their recovery efforts. Performance degradation may continue as recovery efforts on AWS services are performed. We will be closely monitoring our systems throughout this effort.
If you have any questions regarding this issue or require assistance with using alternative MFA, please log a ticket at https://support.secureauth.com. Our teams are on standby and are ready to assist.
Posted Oct 20, 2025 - 11:49 PDT
Update
The ongoing AWS us-east-1 Incident (https://health.aws.amazon.com/health/status) is leading to limited functionality specifically regarding Secureauth PUSH services. Cloud customers will also see limited functionality with EMAIL services. If affected, customers are advised to use alternative MFA methods until the issue is resolved.
We will keep the Secureauth status page updated with any changes, including when service issues are resolved.
If you have any questions regarding this issue or require assistance with using alternative MFA, please log a ticket at https://support.secureauth.com. Our teams are on standby and are ready to assist.
Posted Oct 20, 2025 - 10:17 PDT
Update
The ongoing AWS us-east-1 Incident (https://health.aws.amazon.com/health/status) is leading to limited functionality specifically regarding Secureauth PUSH services. If affected, customers are advised to use alternative MFA methods until the issue is resolved.
We will keep the Secureauth status page updated with any changes, including when service issues are resolved.
If you have any questions regarding this issue or require assistance with using alternative MFA, please log a ticket at https://support.secureauth.com. Our teams are on standby and are ready to assist.
Posted Oct 20, 2025 - 09:34 PDT
Monitoring
All affected service issues are operational. We will continue to work closely with AWS and monitor their recovery efforts. Performance degradation may continue as recovery efforts on AWS services are performed. We will be closely monitoring our systems throughout this effort.
If you have any questions regarding this issue or require assistance with applying the fix, please log a ticket at https://support.secureauth.com. Our teams are on standby and are ready to assist.
Posted Oct 20, 2025 - 02:59 PDT
Investigating
SecureAuth is experiencing major impact to our cloud services due to an ongoing AWS incident within the us-east-1 region. This includes authentication-related functions and 2FA methods such as PUSH notifications. Our teams are actively monitoring AWS recovery efforts and working to restore normal service levels as quickly as possible.
If you have any questions regarding this issue or require assistance with applying the fix, please log a ticket at https://support.secureauth.com. Our teams are on standby and are ready to assist.
Posted Oct 20, 2025 - 00:11 PDT
This incident affected: Workforce (Push, Cloud IdP), Passwordless (Push), and CIAM (US Region).