SMS Delivery Issues
Incident Report for SecureAuth Service
Resolved
This incident has been resolved.
Posted May 30, 2022 - 17:21 PDT
Monitoring
We are waiting on our Telephony provider for a RCA and will continue to monitor the service
Posted May 30, 2022 - 07:33 PDT
Identified
The issue has been identified as a problem with our Telephony Provider and was resolved at 13:39 UTC
Posted May 30, 2022 - 07:32 PDT
Investigating
We are currently investigating this issue.
Posted May 30, 2022 - 07:31 PDT
This incident affected: SecureAuth Cloud Services (SMS Service - US1, SMS Service - US2) and SecureAuth Titan Services (SMS Service).