Dashboard Service is currently experiencing delays.
Incident Report for SecureAuth Service
Resolved
This incident has been resolved
Posted Dec 10, 2020 - 23:25 UTC
Update
We are continuing to monitor for any further issues.
Posted Oct 30, 2020 - 21:31 UTC
Monitoring
A fix has been implemented and dashboard data is now displaying as expected. We will continue to monitor the results.
Posted Oct 30, 2020 - 21:31 UTC
Investigating
We are currently investigating this issue.
Posted Oct 30, 2020 - 16:51 UTC
This incident affected: SecureAuth Titan Services (Dashboard Service).