Slow SMS Delivery
Incident Report for SecureAuth Service
Resolved
The incident has been identified and resolved.
Posted 5 months ago. Jun 06, 2019 - 21:58 UTC
Investigating
We are currently experiencing slow SMS delivery times to some carriers and are investigating the issue.
Posted 5 months ago. Jun 06, 2019 - 21:39 UTC
This incident affected: SMS Service (3rd Party Mobile Carrier).