SMS/Telephony Issues in Hong Kong
Incident Report for SecureAuth Service
Resolved
This incident has been resolved.
Posted Jun 15, 2023 - 15:33 PDT
Monitoring
The provider has implemented a fix and SMS should be delivering successfully to Hong Kong.
Posted Jun 15, 2023 - 13:54 PDT
Identified
Our SMS/Telephony provider is having issues sending SMS/Telephony messages to users in Hong Kong. The provider is working on the issue.
Posted Jun 15, 2023 - 08:02 PDT
This incident affected: SecureAuth Titan Services (SMS Service, Telephony Service).